Product Display Issue on Collection Page
Incident Report for Boost AI Search & Discovery
Resolved
We already fixed for stores which have critical impact and on the process of fixing for the rest.

Please keep in mind that this only affects storefronts having UI customization (HTML/CSS) that relies on "buildExtrasProductListByAjax" to render the custom HTML. The fixing process can be slow because the custom code is very theme-specific, in which we must check and fix case by case.

Besides, the fix will be applied on a duplicated theme. So we will contact you directly when it is in place so that you can double check and publish the theme.
Posted Aug 25, 2023 - 08:15 UTC
Update
We are continuing to monitor for any further issues.
Posted Aug 24, 2023 - 01:12 UTC
Monitoring
We are requesting Shopify to put on hold the release to mitigate the impact.
Posted Aug 23, 2023 - 16:03 UTC
Identified
We are aware of a product display issue that may be occurring as a result of a recent Shopify internal change regarding collection tag filter. This issue may impact storefronts that are using our old theme lib version V2 that use custom function "buildExtrasProductListByAjax"

Specifically, collections with invalid tags now redirect requests to a URL with only valid tags. In cases where all filters are invalid, the redirection is set to the base handle, such as "/collections/all."

During the same conversation with Shopify support team, they also confirmed that "the change was made due to security issue around how it used to work and 3rd parties being able to use the tag filters for SEO hijacks". They will publish a changelog shortly after to announce the change.
Posted Aug 23, 2023 - 11:36 UTC
This incident affected: Storefront UIs.